System.Collections 4.0.0-beta-23019

Provides classes that define generic collections, which allow developers to create strongly typed collections that provide better type safety and performance than non-generic strongly typed collections. Commonly Used Types: System.Collections.Generic.List<T> System.Collections.Generic.Dictionary<TKey, TValue> System.Collections.Generic.Queue<T> System.Collections.Generic.Stack<T> System.Collections.Generic.HashSet<T> System.Collections.Generic.LinkedList<T> System.Collections.Generic.EqualityComparer<T> System.Collections.Generic.Comparer<T> System.Collections.Generic.SortedDictionary<TKey, TValue>

Showing the top 20 packages that depend on System.Collections.

Packages Downloads
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform. When using NuGet 3.x this package requires at least version 3.4.
29
Polly-Signed
Polly is a .NET 3.5 / 4.0 / 4.5 / PCL library (Profile 259) that allows developers to express transient exception handling policies such as Retry, Retry Forever, Wait and Retry or Circuit Breaker in a fluent manner.
6
Portable.BouncyCastle
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you. Crypto features: - Generation and parsing of PKCS-12 files. - X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. - PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. - Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. - Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20. - Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). - Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte. - Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding). - Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1. - AEAD block cipher modes: CCM, EAX, GCM and OCB. - Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool. - XOFs: SHAKE. - Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998. - Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a. - Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC. - PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2. - OpenPGP (RFC 4880) - Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. - Online Certificate Status Protocol (OCSP, RFC 2560). - Time Stamp Protocol (TSP, RFC 3161). - TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available. - Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves. - Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions. - PKIX certificate path validation
6
System.AppContext
Provides the System.AppContext class, which allows access to the BaseDirectory property and other application specific data. Commonly Used Types: System.AppContext
6
System.Composition.Convention
Provides types that support using Managed Extensibility Framework with a convention-based configuration model. Commonly Used Types: System.Composition.Convention.ConventionBuilder System.Composition.Convention.ExportConventionBuilder System.Composition.Convention.ImportConventionBuilder System.Composition.Convention.PartConventionBuilder System.Composition.Convention.ParameterImportConventionBuilder When using NuGet 3.x this package requires at least version 3.4.
7
System.Composition.Hosting
Provides Managed Extensibility Framework types that are useful to developers of extensible applications, or hosts. Commonly Used Types: System.Composition.Hosting.CompositionHost When using NuGet 3.x this package requires at least version 3.4.
7
System.Composition.Runtime
Contains runtime components of the Managed Extensibility Framework. Commonly Used Types: System.Composition.CompositionContext When using NuGet 3.x this package requires at least version 3.4.
7
System.Composition.TypedParts
Provides some extension methods for the Managed Extensibility Framework. Commonly Used Types: System.Composition.CompositionContextExtensions System.Composition.Hosting.ContainerConfiguration When using NuGet 3.x this package requires at least version 3.4.
7
System.Diagnostics.DiagnosticSource
Provides Classes that allow you to decouple code logging rich (unserializable) diagnostics/telemetry (e.g. framework) from code that consumes it (e.g. tools) Commonly Used Types: System.Diagnostics.DiagnosticListener System.Diagnostics.DiagnosticSource
7
System.Diagnostics.DiagnosticSource
Provides Classes that allow you to decouple code logging rich (unserializable) diagnostics/telemetry (e.g. framework) from code that consumes it (e.g. tools) Commonly Used Types: System.Diagnostics.DiagnosticListener System.Diagnostics.DiagnosticSource When using NuGet 3.x this package requires at least version 3.4.
10
System.Linq
Provides classes and interfaces that supports queries that use Language-Integrated Query (LINQ). Commonly Used Types: System.Linq.Enumerable System.Linq.IGrouping<TKey, TElement> System.Linq.IOrderedEnumerable<TElement> System.Linq.ILookup<TKey, TElement> System.Linq.Lookup<TKey, TElement> When using NuGet 3.x this package requires at least version 3.4.
7
System.Linq.Expressions
Provides classes, interfaces and enumerations that enable language-level code expressions to be represented as objects in the form of expression trees. Commonly Used Types: System.Linq.IQueryable<T> System.Linq.IQueryable System.Linq.Expressions.Expression<TDelegate> System.Linq.Expressions.Expression System.Linq.Expressions.ExpressionVisitor When using NuGet 3.x this package requires at least version 3.4.
7
System.ObjectModel
Provides types and interfaces that allow the creation of observable types that provide notifications to clients when changes are made to it. Commonly Used Types: System.ComponentModel.INotifyPropertyChanged System.Collections.ObjectModel.ObservableCollection<T> System.ComponentModel.PropertyChangedEventHandler System.Windows.Input.ICommand System.Collections.Specialized.INotifyCollectionChanged System.Collections.Specialized.NotifyCollectionChangedEventArgs System.Collections.Specialized.NotifyCollectionChangedEventHandler System.Collections.ObjectModel.KeyedCollection<TKey, TItem> System.ComponentModel.PropertyChangedEventArgs System.Collections.ObjectModel.ReadOnlyDictionary<TKey, TValue> When using NuGet 3.x this package requires at least version 3.4.
7
System.Reflection.DispatchProxy
Provides a class to dynamcially create proxy types that implement a specified interface and derive from a specified DispatchProxy type. Method invocations on the generated proxyinstance are dispatched to that DispatchProxy base type. Commonly Used Types: System.Reflection.DispatchProxy
6
System.Security.Principal.Windows
Provides classes for retrieving the current Windows user and for interacting with Windows users and groups. Commonly Used Types: System.Security.Principal.WindowsIdentity System.Security.Principal.SecurityIdentifier System.Security.Principal.NTAccount System.Security.Principal.WindowsPrincipal System.Security.Principal.IdentityReference System.Security.Principal.IdentityNotMappedException System.Security.Principal.WindowsBuiltInRole System.Security.Principal.WellKnownSidType When using NuGet 3.x this package requires at least version 3.4.
17
System.Threading.Tasks.Extensions
Provides additional types that simplify the work of writing concurrent and asynchronous code. Commonly Used Types: System.Threading.Tasks.ValueTask<TResult> 7601f4f6225089ffb291dc7d58293c7bbf5c5d4f
86
xunit.assert
Includes the assertion library from xUnit.net (xunit.assert.dll). Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows 8 - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
6
xunit.assert
Includes the assertion library from xUnit.net (xunit.assert.dll). Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows 8 - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
7
xunit.assert
Includes the assertion library from xUnit.net (xunit.assert.dll). Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
7

.NETPlatform 5.0

.NET Framework 4.5

  • No dependencies.

Windows 8.0

  • No dependencies.

.NETCore 5.0

Version Downloads Last updated
4.3.0 6 04/24/2026
4.3.0-preview1-24530-04 5 04/24/2026
4.0.11 5 04/24/2026
4.0.11-rc2-24027 5 04/24/2026
4.0.11-beta-23516 5 04/24/2026
4.0.11-beta-23409 5 04/24/2026
4.0.11-beta-23225 5 04/24/2026
4.0.10 5 04/24/2026
4.0.10-beta-23109 5 04/24/2026
4.0.10-beta-23019 5 04/24/2026
4.0.10-beta-22816 4 04/24/2026
4.0.10-beta-22605 5 04/24/2026
4.0.10-beta-22416 5 04/24/2026
4.0.10-beta-22231 5 04/24/2026
4.0.0 5 04/25/2026
4.0.0-beta-23109 5 04/24/2026
4.0.0-beta-23019 5 04/24/2026