System.IO.FileSystem 4.0.0-beta-22816
Provides types that allow reading and writing to files and types that provide basic file and directory support.
Commonly Used Types:
System.IO.FileStream
System.IO.FileInfo
System.IO.DirectoryInfo
System.IO.FileSystemInfo
System.IO.File
System.IO.Directory
System.IO.SearchOption
System.IO.FileOptions
Showing the top 20 packages that depend on System.IO.FileSystem.
| Packages | Downloads |
|---|---|
|
Castle.Core
Castle Project Core, including DynamicProxy, Logging Abstractions and DictionaryAdapter
|
6 |
|
log4net
log4net is a tool to help the programmer output log statements to a variety of output targets. In case of problems with an application, it is helpful to enable logging so that the problem can be located. With log4net it is possible to enable logging at runtime without modifying the application binary. The log4net package is designed so that log statements can remain in shipped code without incurring a high performance cost. It follows that the speed of logging (or rather not logging) is crucial.
At the same time, log output can be so voluminous that it quickly becomes overwhelming. One of the distinctive features of log4net is the notion of hierarchical loggers. Using these loggers it is possible to selectively control which log statements are output at arbitrary granularity.
log4net is designed with two distinct goals in mind: speed and flexibility
|
8 |
|
Microsoft.Build
This package contains the Microsoft.Build assembly which is used to create, edit, and evaluation MSBuild projects.
|
6 |
|
Microsoft.Build.Utilities.Core
This package contains the Microsoft.Build.Utilities.Core assembly which is used to implement custom MSBuild tasks.
|
6 |
|
Microsoft.CodeAnalysis.Common
A shared package used by the Microsoft .NET Compiler Platform ("Roslyn"). Do not install this package manually, it will be added as a prerequisite by other packages that require it.
|
6 |
|
Microsoft.CodeAnalysis.Scripting.Common
Microsoft .NET Compiler Platform ("Roslyn") shared scripting package. Do not install this package manually, it will be added as a prerequisite by other packages that require it.
|
6 |
|
Microsoft.CodeAnalysis.Scripting.Common
Microsoft .NET Compiler Platform ("Roslyn") shared scripting package.
Do not install this package manually, it will be added as a prerequisite by other packages that require it.
More details at https://aka.ms/roslyn-packages
This package was built from the source at https://github.com/dotnet/roslyn/commit/e595ee276d14e14bfb3eb323fb57f2aa668bddea
|
6 |
|
Microsoft.NETCore
Provides a set of packages that can be used when building portable libraries on .NETCore based platforms.
|
6 |
|
Microsoft.TestPlatform.ObjectModel
The Microsoft Test Platform Object Model.
|
6 |
|
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together.
b7f182415927d3b98445d043e1680c56b9d1f17c
When using NuGet 3.x this package requires at least version 3.4.
|
6 |
|
NETStandard.Library
A set of standard .NET API's that are prescribed to be used and supported together. This includes all low level API's that all .NET platforms must support.
TFS ID: 1599443, GitHub SHA: https://github.com/dotnet/corefx/tree/eede273a4dfabcea608621f5e1bbf8ad00584cfb
|
6 |
|
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform.
When using NuGet 3.x this package requires at least version 3.4.
|
29 |
|
NetTopologySuite.CoordinateSystems
The NTS Topology Suite is an API for modelling and manipulating 2-dimensional linear geometry. It provides numerous geometric predicates and functions. NTS conforms to the Simple Features Specification.
This package references GeoAPI.
|
6 |
|
NetTopologySuite.Core
The NTS Topology Suite is an API for modelling and manipulating 2-dimensional linear geometry. It provides numerous geometric predicates and functions. NTS conforms to the Simple Features Specification.
This package references GeoAPI.
|
6 |
|
Portable.BouncyCastle
BouncyCastle.Crypto is a cryptography API providing:
-Generation and parsing of PKCS#12 files.
-X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates.
-PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256.
-Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA.
-Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC.
-Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR).
-Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte.
-Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA.
-Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1.
-Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool.
-Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA.
-Key Agreement: Diffie-Hellman and EC-DH.
-Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3.
-PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2.
-OpenPGP (RFC 2440)
-Cryptographic Message Syntax (CMS, RFC 3852), including streaming API.
-Online Certificate Status Protocol (OCSP, RFC 2560).
-Time Stamp Protocol (TSP, RFC 3161).
-TLS/SSL Client with support for client side authentication.
Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR
|
6 |
|
Portable.BouncyCastle
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR
IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you.
Crypto features:
- Generation and parsing of PKCS-12 files.
- X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates.
- PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256.
- Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA.
- Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20.
- Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR).
- Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte.
- Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding).
- Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1.
- AEAD block cipher modes: CCM, EAX, GCM and OCB.
- Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool.
- XOFs: SHAKE.
- Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998.
- Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a.
- Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC.
- PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2.
- OpenPGP (RFC 4880)
- Cryptographic Message Syntax (CMS, RFC 3852), including streaming API.
- Online Certificate Status Protocol (OCSP, RFC 2560).
- Time Stamp Protocol (TSP, RFC 3161).
- TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available.
- Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves.
- Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions.
- PKIX certificate path validation
|
6 |
|
StackExchange.Redis
High performance Redis client, incorporating both synchronous and asynchronous usage.
|
6 |
|
System.Diagnostics.FileVersionInfo
Provides the System.Diagnostics.FileVersionInfo class, which allows access to Win32 version resource information for a physical file on disk.
Commonly Used Types:
System.Diagnostics.FileVersionInfo
|
6 |
|
System.IO.MemoryMappedFiles
Provides classes for using a memory-mapped file, which maps the contents of a file to an application's logical address space.
Commonly Used Types:
System.IO.MemoryMappedFiles.MemoryMappedViewAccessor
System.IO.MemoryMappedFiles.MemoryMappedViewStream
System.IO.MemoryMappedFiles.MemoryMappedFile
System.IO.MemoryMappedFiles.MemoryMappedFileAccess
When using NuGet 3.x this package requires at least version 3.4.
|
6 |
Any 0.0
- System.IO (>= 4.0.10-beta-22816)
- System.IO.FileSystem.Primitives (>= 4.0.0-beta-22816)
- System.Runtime (>= 4.0.20-beta-22816)
- System.Runtime.Handles (>= 4.0.0-beta-22816)
- System.Text.Encoding (>= 4.0.10-beta-22816)
- System.Threading.Tasks (>= 4.0.10-beta-22816)
| Version | Downloads | Last updated |
|---|---|---|
| 4.3.0 | 5 | 04/24/2026 |
| 4.3.0-preview1-24530-04 | 5 | 04/16/2026 |
| 4.0.1 | 5 | 04/24/2026 |
| 4.0.1-rc2-24027 | 5 | 04/25/2026 |
| 4.0.1-beta-23516 | 5 | 04/25/2026 |
| 4.0.1-beta-23409 | 5 | 04/25/2026 |
| 4.0.1-beta-23225 | 4 | 04/25/2026 |
| 4.0.0 | 5 | 04/24/2026 |
| 4.0.0-beta-23109 | 5 | 04/25/2026 |
| 4.0.0-beta-23019 | 5 | 04/25/2026 |
| 4.0.0-beta-22816 | 4 | 04/25/2026 |
| 4.0.0-beta-22605 | 5 | 04/25/2026 |
| 4.0.0-beta-22416 | 5 | 04/25/2026 |
| 4.0.0-beta-22231 | 5 | 04/24/2026 |