System.IO 4.3.0-preview1-24530-04

Provides base input and output (I/O) types, including System.IO.Stream, System.IO.StreamReader and System.IO.StreamWriter, that allow reading and writing to data streams Commonly Used Types: System.IO.Stream System.IO.EndOfStreamException System.IO.MemoryStream System.IO.StreamReader System.IO.StreamWriter System.IO.StringWriter System.IO.TextWriter System.IO.TextReader When using NuGet 3.x this package requires at least version 3.4.

Showing the top 20 packages that depend on System.IO.

Packages Downloads
GeoAPI.CoordinateSystems
GeoAPI.NET project provides a common framework based on OGC/ISO standards to improve interoperability among .NET GIS projects.
6
Microsoft.NETCore
Provides a set of packages that can be used when building portable libraries on .NETCore based platforms.
6
Microsoft.NETCore.Runtime.Native
Support libraries for the .NET Core runtime used by .NETNative.
6
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform. When using NuGet 3.x this package requires at least version 3.4.
29
Portable.BouncyCastle
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you. Crypto features: - Generation and parsing of PKCS-12 files. - X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. - PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. - Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. - Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20. - Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). - Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte. - Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding). - Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1. - AEAD block cipher modes: CCM, EAX, GCM and OCB. - Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool. - XOFs: SHAKE. - Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998. - Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a. - Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC. - PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2. - OpenPGP (RFC 4880) - Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. - Online Certificate Status Protocol (OCSP, RFC 2560). - Time Stamp Protocol (TSP, RFC 3161). - TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available. - Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves. - Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions. - PKIX certificate path validation
6
Standart.Hash.xxHash
Standart.Hash.xxHash
7
System.Linq.Expressions
Provides classes, interfaces and enumerations that enable language-level code expressions to be represented as objects in the form of expression trees. Commonly Used Types: System.Linq.IQueryable<T> System.Linq.IQueryable System.Linq.Expressions.Expression<TDelegate> System.Linq.Expressions.Expression System.Linq.Expressions.ExpressionVisitor When using NuGet 3.x this package requires at least version 3.4.
7
System.Net.Http
Provides a programming interface for modern HTTP applications, including HTTP client components that allow applications to consume web services over HTTP and HTTP components that can be used by both clients and servers for parsing HTTP headers. Commonly Used Types: System.Net.Http.HttpResponseMessage System.Net.Http.DelegatingHandler System.Net.Http.HttpRequestException System.Net.Http.HttpClient System.Net.Http.MultipartContent System.Net.Http.Headers.HttpContentHeaders System.Net.Http.HttpClientHandler System.Net.Http.StreamContent System.Net.Http.FormUrlEncodedContent System.Net.Http.HttpMessageHandler When using NuGet 3.x this package requires at least version 3.4.
7
System.Net.Http
Provides classes for sending HTTP requests and receiving HTTP responses from a resource identified by a URI. Commonly Used Types: System.Net.Http.HttpResponseMessage System.Net.Http.DelegatingHandler System.Net.Http.HttpRequestException System.Net.Http.HttpClient System.Net.Http.MultipartContent System.Net.Http.Headers.HttpContentHeaders System.Net.Http.HttpClientHandler System.Net.Http.StreamContent System.Net.Http.FormUrlEncodedContent System.Net.Http.HttpMessageHandler
6
System.Net.Http
Provides modern classes for sending HTTP requests and receiving HTTP responses from a resource identified by a URI. Commonly Used Types: System.Net.Http.HttpResponseMessage System.Net.Http.DelegatingHandler System.Net.Http.HttpRequestException System.Net.Http.HttpClient System.Net.Http.MultipartContent System.Net.Http.Headers.HttpContentHeaders System.Net.Http.HttpClientHandler System.Net.Http.StreamContent System.Net.Http.FormUrlEncodedContent System.Net.Http.HttpMessageHandler
7
System.Net.Sockets
Provides a managed implementation of the Windows Sockets (Winsock) interface for developers who need to tightly control access to the network. Commonly Used Types: System.Net.Sockets.Socket System.Net.Sockets.SocketAsyncEventArgs System.Net.Sockets.LingerOption System.Net.Sockets.SocketAsyncOperation System.Net.Sockets.ProtocolType System.Net.Sockets.NetworkStream System.Net.Sockets.TcpClient System.Net.Sockets.SocketType System.Net.Sockets.UdpClient System.Net.Sockets.SocketShutdown
7
System.Net.Sockets
Provides classes such as Socket, TcpClient and UdpClient, which enable developers to send and receive data over the network. Commonly Used Types: System.Net.Sockets.Socket System.Net.Sockets.SocketAsyncEventArgs System.Net.Sockets.LingerOption System.Net.Sockets.SocketAsyncOperation System.Net.Sockets.ProtocolType System.Net.Sockets.NetworkStream System.Net.Sockets.TcpClient System.Net.Sockets.SocketType System.Net.Sockets.UdpClient System.Net.Sockets.SocketShutdown When using NuGet 3.x this package requires at least version 3.4.
7
System.Reflection
Provides types that retrieve information about assemblies, modules, members, parameters, and other entities in managed code by examining their metadata. These types also can be used to manipulate instances of loaded types, for example to hook up events or to invoke methods. Commonly Used Types: System.Reflection.MethodInfo System.Reflection.PropertyInfo System.Reflection.ParameterInfo System.Reflection.FieldInfo System.Reflection.ConstructorInfo System.Reflection.Assembly System.Reflection.MemberInfo System.Reflection.EventInfo System.Reflection.Module
7
System.Reflection
Provides types that retrieve information about assemblies, modules, members, parameters, and other entities in managed code by examining their metadata. These types also can be used to manipulate instances of loaded types, for example to hook up events or to invoke methods. Commonly Used Types: System.Reflection.MethodInfo System.Reflection.PropertyInfo System.Reflection.ParameterInfo System.Reflection.FieldInfo System.Reflection.ConstructorInfo System.Reflection.Assembly System.Reflection.MemberInfo System.Reflection.EventInfo System.Reflection.Module When using NuGet 3.x this package requires at least version 3.4.
13
System.Reflection.Emit
Provides classes that allow a compiler or tool to emit metadata and optionally generate a PE file on disk. The primary clients of these classes are script engines and compilers. Commonly Used Types: System.Reflection.Emit.AssemblyBuilder System.Reflection.Emit.FieldBuilder System.Reflection.Emit.TypeBuilder System.Reflection.Emit.MethodBuilder System.Reflection.Emit.ConstructorBuilder System.Reflection.Emit.GenericTypeParameterBuilder System.Reflection.Emit.ModuleBuilder System.Reflection.Emit.PropertyBuilder System.Reflection.Emit.AssemblyBuilderAccess System.Reflection.Emit.EventBuilder When using NuGet 3.x this package requires at least version 3.4.
7
System.Reflection.Emit
Provides classes that allow a compiler or tool to emit metadata and optionally generate a PE file on disk. The primary clients of these classes are script engines and compilers. Commonly Used Types: System.Reflection.Emit.AssemblyBuilder System.Reflection.Emit.FieldBuilder System.Reflection.Emit.TypeBuilder System.Reflection.Emit.MethodBuilder System.Reflection.Emit.ConstructorBuilder System.Reflection.Emit.GenericTypeParameterBuilder System.Reflection.Emit.ModuleBuilder System.Reflection.Emit.PropertyBuilder System.Reflection.Emit.AssemblyBuilderAccess System.Reflection.Emit.EventBuilder When using NuGet 3.x this package requires at least version 3.4.
13
System.Security.Cryptography.Cng
Provides cryptographic algorithm implementations and key management with Windows Cryptographic Next Generation API (CNG). Commonly Used Types: System.Security.Cryptography.RSACng System.Security.Cryptography.ECDsaCng System.Security.Cryptography.CngKey 30ab651fcb4354552bd4891619a0bdd81e0ebdbf When using NuGet 3.x this package requires at least version 3.4.
7
System.Security.Cryptography.Cng
Provides cryptographic algorithm implementations and key management with Windows Cryptographic Next Generation API (CNG). Commonly Used Types: System.Security.Cryptography.RSACng System.Security.Cryptography.ECDsaCng System.Security.Cryptography.CngKey When using NuGet 3.x this package requires at least version 3.4.
17
System.ServiceModel.Primitives
Provides common Windows Communication Foundation (WCF) types for consuming and communicating with services. Commonly Used Types: System.ServiceModel.ClientBase<TChannel> System.ServiceModel.IClientChannel System.ServiceModel.ICommunicationObject System.ServiceModel.Channels.IChannel System.ServiceModel.IContextChannel System.ServiceModel.IExtensibleObject<T> System.ServiceModel.DataContractFormatAttribute System.ServiceModel.Description.IOperationBehavior System.ServiceModel.Channels.Message System.ServiceModel.FaultException<TDetail>
7
System.Xml.XDocument
Provides the classes for Language-Integrated Query (LINQ) to Extensible Markup Language (XML). LINQ to XML is an in-memory XML programming interface that enables you to modify XML documents efficiently and easily. Commonly Used Types: System.Xml.Linq.XElement System.Xml.Linq.XAttribute System.Xml.Linq.XDocument System.Xml.Linq.XText System.Xml.Linq.XNode System.Xml.Linq.XContainer System.Xml.Linq.XComment System.Xml.Linq.XObject System.Xml.Linq.XProcessingInstruction System.Xml.Linq.XDocumentType
6

MonoAndroid 1.0

  • No dependencies.

MonoTouch 1.0

  • No dependencies.

.NET Framework 4.5

  • No dependencies.

.NET Framework 4.6.2

  • No dependencies.

.NETCore 5.0

.NET Standard 1.0

.NET Standard 1.3

.NET Standard 1.5

.NETPortable 0.0

  • No dependencies.

Windows 8.0

  • No dependencies.

WindowsPhone 8.0

  • No dependencies.

WindowsPhoneApp 8.1

  • No dependencies.

Xamarin.iOS 1.0

  • No dependencies.

Xamarin.Mac 2.0

  • No dependencies.

Xamarin.TVOS 1.0

  • No dependencies.

Xamarin.WatchOS 1.0

  • No dependencies.

Version Downloads Last updated
4.3.0 11 05/16/2026
4.3.0-preview1-24530-04 5 04/24/2026
4.1.0 5 04/24/2026
4.1.0-rc2-24027 5 04/24/2026
4.0.11-beta-23516 5 04/24/2026
4.0.11-beta-23409 5 04/24/2026
4.0.11-beta-23225 5 04/24/2026
4.0.10 5 04/24/2026
4.0.10-beta-23109 5 04/24/2026
4.0.10-beta-23019 5 04/24/2026
4.0.10-beta-22816 4 04/24/2026
4.0.10-beta-22605 5 04/24/2026
4.0.10-beta-22416 5 04/24/2026
4.0.10-beta-22231 5 04/24/2026
4.0.0 5 04/24/2026
4.0.0-beta-23109 5 04/25/2026
4.0.0-beta-23019 5 04/25/2026