System.Reflection.Extensions 4.0.1-rc2-24027

Provides custom attribute extension methods for System.Reflection types. Commonly Used Types: System.Reflection.InterfaceMapping System.Reflection.CustomAttributeExtensions System.Reflection.RuntimeReflectionExtensions \r\n TFS ID: 1599443, GitHub SHA: https://github.com/dotnet/corefx/tree/eede273a4dfabcea608621f5e1bbf8ad00584cfb

Showing the top 20 packages that depend on System.Reflection.Extensions.

Packages Downloads
log4net
log4net is a tool to help the programmer output log statements to a variety of output targets. In case of problems with an application, it is helpful to enable logging so that the problem can be located. With log4net it is possible to enable logging at runtime without modifying the application binary. The log4net package is designed so that log statements can remain in shipped code without incurring a high performance cost. It follows that the speed of logging (or rather not logging) is crucial. At the same time, log output can be so voluminous that it quickly becomes overwhelming. One of the distinctive features of log4net is the notion of hierarchical loggers. Using these loggers it is possible to selectively control which log statements are output at arbitrary granularity. log4net is designed with two distinct goals in mind: speed and flexibility
6
log4net
log4net is a tool to help the programmer output log statements to a variety of output targets. In case of problems with an application, it is helpful to enable logging so that the problem can be located. With log4net it is possible to enable logging at runtime without modifying the application binary. The log4net package is designed so that log statements can remain in shipped code without incurring a high performance cost. It follows that the speed of logging (or rather not logging) is crucial. At the same time, log output can be so voluminous that it quickly becomes overwhelming. One of the distinctive features of log4net is the notion of hierarchical loggers. Using these loggers it is possible to selectively control which log statements are output at arbitrary granularity. log4net is designed with two distinct goals in mind: speed and flexibility
8
Microsoft.AspNetCore.Mvc.Abstractions
ASP.NET Core MVC abstractions and interfaces for action invocation and dispatching, authorization, action filters, formatters, model binding, routing, validation, and more. Commonly used types: Microsoft.AspNetCore.Mvc.IActionResult
6
Microsoft.AspNet.DataProtection
ASP.NET 5 logic to protect and unprotect data, similar to DPAPI.
6
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform. When using NuGet 3.x this package requires at least version 3.4.
29
Portable.BouncyCastle
BouncyCastle.Crypto is a cryptography API providing: -Generation and parsing of PKCS#12 files. -X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. -PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. -Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. -Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC. -Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). -Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte. -Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA. -Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1. -Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool. -Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA. -Key Agreement: Diffie-Hellman and EC-DH. -Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3. -PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2. -OpenPGP (RFC 2440) -Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. -Online Certificate Status Protocol (OCSP, RFC 2560). -Time Stamp Protocol (TSP, RFC 3161). -TLS/SSL Client with support for client side authentication. Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR
6
Portable.BouncyCastle
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you. Crypto features: - Generation and parsing of PKCS-12 files. - X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. - PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. - Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. - Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20. - Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). - Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte. - Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding). - Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1. - AEAD block cipher modes: CCM, EAX, GCM and OCB. - Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool. - XOFs: SHAKE. - Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998. - Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a. - Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC. - PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2. - OpenPGP (RFC 4880) - Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. - Online Certificate Status Protocol (OCSP, RFC 2560). - Time Stamp Protocol (TSP, RFC 3161). - TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available. - Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves. - Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions. - PKIX certificate path validation
6
Remotion.Linq
re-linq Frontend: A foundation for parsing LINQ expression trees and generating queries in SQL or other languages. Key features: - Transforms expression trees into abstract syntax trees resemblying LINQ query expressions (from ... select syntax) - Simplifies many aspects of this tree (sub queries, transparent identifieres, pre-evaluation ...) - Provides basic infrastructure for backend development (e.g. SQL generation) - Provides a framework for user-defined query extensions and transformations
6
System.Composition.Convention
Provides types that support using Managed Extensibility Framework with a convention-based configuration model. Commonly Used Types: System.Composition.Convention.ConventionBuilder System.Composition.Convention.ExportConventionBuilder System.Composition.Convention.ImportConventionBuilder System.Composition.Convention.PartConventionBuilder System.Composition.Convention.ParameterImportConventionBuilder When using NuGet 3.x this package requires at least version 3.4.
7
System.Composition.Hosting
Provides Managed Extensibility Framework types that are useful to developers of extensible applications, or hosts. Commonly Used Types: System.Composition.Hosting.CompositionHost When using NuGet 3.x this package requires at least version 3.4.
7
System.Composition.TypedParts
Provides some extension methods for the Managed Extensibility Framework. Commonly Used Types: System.Composition.CompositionContextExtensions System.Composition.Hosting.ContainerConfiguration When using NuGet 3.x this package requires at least version 3.4.
7
System.Linq.Expressions
Provides classes, interfaces and enumerations that enable language-level code expressions to be represented as objects in the form of expression trees. Commonly Used Types: System.Linq.IQueryable<T> System.Linq.IQueryable System.Linq.Expressions.Expression<TDelegate> System.Linq.Expressions.Expression System.Linq.Expressions.ExpressionVisitor When using NuGet 3.x this package requires at least version 3.4.
7
System.Private.ServiceModel
Internal implementation package not meant for direct consumption. Please do not reference directly. Provides implementation of System.ServiceModel packages.
6
System.Private.ServiceModel
Internal implementation package not meant for direct consumption. Please do not reference directly. Provides implementation of System.ServiceModel packages. When using NuGet 3.x this package requires at least version 3.4.
6
System.Reflection.DispatchProxy
Provides a class to dynamcially create proxy types that implement a specified interface and derive from a specified DispatchProxy type. Method invocations on the generated proxyinstance are dispatched to that DispatchProxy base type. Commonly Used Types: System.Reflection.DispatchProxy
6
System.Xml.XmlSerializer
Provides classes for serializing objects to the Extensible Markup Language (XML) and deserializing XML data to objects. Commonly Used Types: System.Xml.Serialization.IXmlSerializable System.Xml.Serialization.XmlSerializer System.Xml.Serialization.XmlIgnoreAttribute System.Xml.Serialization.XmlElementAttribute System.Xml.Serialization.XmlAttributeAttribute System.Xml.Serialization.XmlArrayAttribute System.Xml.Serialization.XmlRootAttribute System.Xml.Serialization.XmlArrayItemAttribute System.Xml.Serialization.XmlTypeAttribute System.Xml.Serialization.XmlEnumAttribute
6
xunit.assert
Includes the assertion library from xUnit.net (xunit.assert.dll). Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows 8 - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
7
xunit.assert
Includes the assertion library from xUnit.net (xunit.assert.dll). Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
7
xunit.core
Includes the libraries for writing unit tests with xUnit.net. Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows 8 - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
6
xunit.extensibility.execution
Includes xunit.execution.*.dll for extensibility purposes. Supported platforms: Desktop .NET 4.5+, DNX 4.5.1+, DNX Core 5+, Modern Windows 8, Windows Phone 8 (Silverlight), Universal (Windows Phone 8.1+, Windows 8.1+), MonoTouch, MonoAndroid, Xamarin iOS Universal.
6

MonoAndroid 1.0

  • No dependencies.

MonoTouch 1.0

  • No dependencies.

.NET Framework 4.5

  • No dependencies.

.NETCore 5.0

.NET Standard 1.0

.NETPortable 0.0

  • No dependencies.

Windows 8.0

  • No dependencies.

WindowsPhone 8.0

  • No dependencies.

WindowsPhoneApp 8.1

  • No dependencies.

Xamarin.iOS 1.0

  • No dependencies.

Xamarin.Mac 2.0

  • No dependencies.

Xamarin.TVOS 1.0

  • No dependencies.

Xamarin.WatchOS 1.0

  • No dependencies.

Version Downloads Last updated
4.3.0 7 04/23/2026
4.3.0-preview1-24530-04 5 04/25/2026
4.0.1 5 04/25/2026
4.0.1-rc2-24027 5 04/25/2026
4.0.1-beta-23516 5 04/25/2026
4.0.1-beta-23409 5 04/25/2026
4.0.1-beta-23225 5 04/25/2026
4.0.0 5 04/24/2026
4.0.0-beta-23109 5 04/25/2026
4.0.0-beta-23019 5 04/25/2026
4.0.0-beta-22816 5 04/25/2026
4.0.0-beta-22605 5 04/25/2026
4.0.0-beta-22416 5 04/25/2026
4.0.0-beta-22231 5 04/25/2026