System.Runtime.Extensions 4.0.10-beta-22605

Provides commonly-used classes for performing mathematical functions, conversions, string comparisons and querying environment information. Commonly Used Types: System.Math System.Environment System.Random System.Progress<T> System.Convert System.Diagnostics.Stopwatch System.Runtime.Versioning.FrameworkName System.StringComparer System.IO.Path

Showing the top 20 packages that depend on System.Runtime.Extensions.

Packages Downloads
Confluent.Kafka
Confluent's .NET Client for Apache Kafka
9
GeoAPI.CoordinateSystems
GeoAPI.NET project provides a common framework based on OGC/ISO standards to improve interoperability among .NET GIS projects.
6
log4net
log4net is a tool to help the programmer output log statements to a variety of output targets. In case of problems with an application, it is helpful to enable logging so that the problem can be located. With log4net it is possible to enable logging at runtime without modifying the application binary. The log4net package is designed so that log statements can remain in shipped code without incurring a high performance cost. It follows that the speed of logging (or rather not logging) is crucial. At the same time, log output can be so voluminous that it quickly becomes overwhelming. One of the distinctive features of log4net is the notion of hierarchical loggers. Using these loggers it is possible to selectively control which log statements are output at arbitrary granularity. log4net is designed with two distinct goals in mind: speed and flexibility
8
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform. When using NuGet 3.x this package requires at least version 3.4.
29
Portable.BouncyCastle
BouncyCastle.Crypto is a cryptography API providing: -Generation and parsing of PKCS#12 files. -X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. -PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. -Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. -Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC. -Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). -Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte. -Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA. -Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1. -Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool. -Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA. -Key Agreement: Diffie-Hellman and EC-DH. -Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3. -PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2. -OpenPGP (RFC 2440) -Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. -Online Certificate Status Protocol (OCSP, RFC 2560). -Time Stamp Protocol (TSP, RFC 3161). -TLS/SSL Client with support for client side authentication. Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR
6
System.Composition.TypedParts
Provides some extension methods for the Managed Extensibility Framework. Commonly Used Types: System.Composition.CompositionContextExtensions System.Composition.Hosting.ContainerConfiguration When using NuGet 3.x this package requires at least version 3.4.
7
System.Diagnostics.DiagnosticSource
Provides Classes that allow you to decouple code logging rich (unserializable) diagnostics/telemetry (e.g. framework) from code that consumes it (e.g. tools) Commonly Used Types: System.Diagnostics.DiagnosticListener System.Diagnostics.DiagnosticSource When using NuGet 3.x this package requires at least version 3.4.
10
System.Linq
Provides classes and interfaces that supports queries that use Language-Integrated Query (LINQ). Commonly Used Types: System.Linq.Enumerable System.Linq.IGrouping<TKey, TElement> System.Linq.IOrderedEnumerable<TElement> System.Linq.ILookup<TKey, TElement> System.Linq.Lookup<TKey, TElement> When using NuGet 3.x this package requires at least version 3.4.
7
System.Linq.Expressions
Provides classes, interfaces and enumerations that enable language-level code expressions to be represented as objects in the form of expression trees. Commonly Used Types: System.Linq.IQueryable<T> System.Linq.IQueryable System.Linq.Expressions.Expression<TDelegate> System.Linq.Expressions.Expression System.Linq.Expressions.ExpressionVisitor When using NuGet 3.x this package requires at least version 3.4.
7
System.Memory
Provides types for efficient representation and pooling of managed, stack, and native memory segments and sequences of such segments, along with primitives to parse and format UTF-8 encoded text stored in those memory segments. Commonly Used Types: System.Span System.ReadOnlySpan System.Memory System.ReadOnlyMemory System.Buffers.MemoryPool System.Buffers.ReadOnlySequence System.Buffers.Text.Utf8Parser System.Buffers.Text.Utf8Formatter 7601f4f6225089ffb291dc7d58293c7bbf5c5d4f When using NuGet 3.x this package requires at least version 3.4.
148
System.Memory
Provides types for efficient representation and pooling of managed, stack, and native memory segments and sequences of such segments, along with primitives to parse and format UTF-8 encoded text stored in those memory segments. Commonly Used Types: System.Span System.ReadOnlySpan System.Memory System.ReadOnlyMemory System.Buffers.MemoryPool System.Buffers.ReadOnlySequence System.Buffers.Text.Utf8Parser System.Buffers.Text.Utf8Formatter c6cf790234e063b855fcdb50f3fb1b3cfac73275 When using NuGet 3.x this package requires at least version 3.4.
17
System.Reflection.TypeExtensions
Provides extensions methods for System.Type that are designed to be source-compatible with older framework reflection-based APIs. Commonly Used Types: System.Reflection.TypeExtensions System.Reflection.BindingFlags 7e3dbdb95b30650eabade0ac73a10b22d4dbe8b3 When using NuGet 3.x this package requires at least version 3.4.
6
System.Reflection.TypeExtensions
Provides extensions methods for System.Type that are designed to be source-compatible with older framework reflection-based APIs. Commonly Used Types: System.Reflection.TypeExtensions System.Reflection.BindingFlags When using NuGet 3.x this package requires at least version 3.4.
6
System.Security.Cryptography.Algorithms
Provides base types for cryptographic algorithms, including hashing, encryption, and signing operations. Commonly Used Types: System.Security.Cryptography.Aes System.Security.Cryptography.RSA System.Security.Cryptography.RSAParameters System.Security.Cryptography.HMACSHA1 System.Security.Cryptography.SHA256 System.Security.Cryptography.SHA1 System.Security.Cryptography.SHA512 System.Security.Cryptography.SHA384 System.Security.Cryptography.HMACSHA256 System.Security.Cryptography.MD5 System.Security.Cryptography.HMACSHA384 System.Security.Cryptography.HMACSHA512 When using NuGet 3.x this package requires at least version 3.4.
6
System.Security.Cryptography.Cng
Provides cryptographic algorithm implementations and key management with Windows Cryptographic Next Generation API (CNG). Commonly Used Types: System.Security.Cryptography.RSACng System.Security.Cryptography.ECDsaCng System.Security.Cryptography.CngKey 30ab651fcb4354552bd4891619a0bdd81e0ebdbf When using NuGet 3.x this package requires at least version 3.4.
7
System.Security.Cryptography.Cng
Provides cryptographic algorithm implementations and key management with Windows Cryptographic Next Generation API (CNG). Commonly Used Types: System.Security.Cryptography.RSACng System.Security.Cryptography.ECDsaCng System.Security.Cryptography.CngKey When using NuGet 3.x this package requires at least version 3.4.
17
System.Security.Principal.Windows
Provides classes for retrieving the current Windows user and for interacting with Windows users and groups. Commonly Used Types: System.Security.Principal.WindowsIdentity System.Security.Principal.SecurityIdentifier System.Security.Principal.NTAccount System.Security.Principal.WindowsPrincipal System.Security.Principal.IdentityReference System.Security.Principal.IdentityNotMappedException System.Security.Principal.WindowsBuiltInRole System.Security.Principal.WellKnownSidType When using NuGet 3.x this package requires at least version 3.4.
17
System.Xml.XPath
Provides the classes that define a cursor model for navigating and editing Extensible Markup Language (XML) information items as instances of the XQuery 1.0 and XPath 2.0 Data Model. Commonly Used Types: System.Xml.XPath.XPathNavigator System.Xml.XPath.IXPathNavigable System.Xml.XPath.XPathNodeType System.Xml.XPath.XPathNodeIterator System.Xml.XPath.XPathExpression System.Xml.XPath.XPathResultType System.Xml.XPath.XPathException System.Xml.XPath.XPathDocument System.Xml.XPath.XPathItem System.Xml.XPath.XPathNamespaceScope - 1548494
6
xunit.assert
Includes the assertion library from xUnit.net (xunit.assert.dll). Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows 8 - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
7
xunit.assert
Includes the assertion library from xUnit.net (xunit.assert.dll). Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
7

Any 0.0

Version Downloads Last updated
4.3.1 5 04/25/2026
4.3.0 6 04/25/2026
4.3.0-preview1-24530-04 5 04/25/2026
4.1.2 5 04/25/2026
4.1.1 5 04/25/2026
4.1.0 5 04/25/2026
4.1.0-rc2-24027 5 04/25/2026
4.0.11-beta-23516 5 04/25/2026
4.0.11-beta-23409 5 04/25/2026
4.0.11-beta-23225 5 04/25/2026
4.0.10 5 04/25/2026
4.0.10-beta-23109 6 04/16/2026
4.0.10-beta-23019 5 04/25/2026
4.0.10-beta-22816 5 04/25/2026
4.0.10-beta-22605 5 04/25/2026
4.0.10-beta-22416 5 04/25/2026
4.0.10-beta-22231 5 04/25/2026
4.0.0 5 04/25/2026
4.0.0-beta-23109 5 04/25/2026
4.0.0-beta-23019 5 04/25/2026