System.Threading 4.0.0-beta-23019

Provides the fundamental synchronization primitives, including System.Threading.Monitor and System.Threading.Mutex, that are required when writing asynchronous code. Commonly Used Types: System.Threading.Monitor System.Threading.SynchronizationContext System.Threading.ManualResetEvent System.Threading.AutoResetEvent System.Threading.ThreadLocal<T> System.Threading.EventWaitHandle System.Threading.SemaphoreSlim System.Threading.Mutex

Showing the top 20 packages that depend on System.Threading.

Packages Downloads
Confluent.Kafka
Confluent's .NET Client for Apache Kafka
9
log4net
log4net is a tool to help the programmer output log statements to a variety of output targets. In case of problems with an application, it is helpful to enable logging so that the problem can be located. With log4net it is possible to enable logging at runtime without modifying the application binary. The log4net package is designed so that log statements can remain in shipped code without incurring a high performance cost. It follows that the speed of logging (or rather not logging) is crucial. At the same time, log output can be so voluminous that it quickly becomes overwhelming. One of the distinctive features of log4net is the notion of hierarchical loggers. Using these loggers it is possible to selectively control which log statements are output at arbitrary granularity. log4net is designed with two distinct goals in mind: speed and flexibility
8
Microsoft.NETCore
Provides a set of packages that can be used when building portable libraries on .NETCore based platforms.
6
Microsoft.NETCore.Runtime.Native
Support libraries for the .NET Core runtime used by .NETNative.
6
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform. When using NuGet 3.x this package requires at least version 3.4.
29
Polly
Polly is a .NET 3.5 / 4.0 / 4.5 / PCL library (Profile 259) that allows developers to express transient exception handling policies such as Retry, Retry Forever, Wait and Retry or Circuit Breaker in a fluent manner.
6
Portable.BouncyCastle
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you. Crypto features: - Generation and parsing of PKCS-12 files. - X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. - PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. - Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. - Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20. - Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). - Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte. - Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding). - Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1. - AEAD block cipher modes: CCM, EAX, GCM and OCB. - Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool. - XOFs: SHAKE. - Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998. - Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a. - Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC. - PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2. - OpenPGP (RFC 4880) - Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. - Online Certificate Status Protocol (OCSP, RFC 2560). - Time Stamp Protocol (TSP, RFC 3161). - TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available. - Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves. - Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions. - PKIX certificate path validation
6
System.Buffers
Provides resource pooling of any type for performance-critical applications that allocate and deallocate objects frequently. Commonly Used Types: System.Buffers.ArrayPool<T> 7601f4f6225089ffb291dc7d58293c7bbf5c5d4f When using NuGet 3.x this package requires at least version 3.4.
115
System.Collections.NonGeneric
Provides classes that define older non-generic collections of objects, such as lists, queues, hash tables and dictionaries. Developers should prefer the generic collections in the System.Collections package. Commonly Used Types: System.Collections.ArrayList System.Collections.Hashtable System.Collections.CollectionBase System.Collections.ReadOnlyCollectionBase System.Collections.Stack System.Collections.SortedList System.Collections.DictionaryBase System.Collections.Queue System.Collections.Comparer System.Collections.CaseInsensitiveComparer
6
System.Composition.Convention
Provides types that support using Managed Extensibility Framework with a convention-based configuration model. Commonly Used Types: System.Composition.Convention.ConventionBuilder System.Composition.Convention.ExportConventionBuilder System.Composition.Convention.ImportConventionBuilder System.Composition.Convention.PartConventionBuilder System.Composition.Convention.ParameterImportConventionBuilder When using NuGet 3.x this package requires at least version 3.4.
7
System.Composition.Hosting
Provides Managed Extensibility Framework types that are useful to developers of extensible applications, or hosts. Commonly Used Types: System.Composition.Hosting.CompositionHost When using NuGet 3.x this package requires at least version 3.4.
7
System.Diagnostics.DiagnosticSource
Provides Classes that allow you to decouple code logging rich (unserializable) diagnostics/telemetry (e.g. framework) from code that consumes it (e.g. tools) Commonly Used Types: System.Diagnostics.DiagnosticListener System.Diagnostics.DiagnosticSource
7
System.Diagnostics.DiagnosticSource
Provides Classes that allow you to decouple code logging rich (unserializable) diagnostics/telemetry (e.g. framework) from code that consumes it (e.g. tools) Commonly Used Types: System.Diagnostics.DiagnosticListener System.Diagnostics.DiagnosticSource When using NuGet 3.x this package requires at least version 3.4.
10
System.Linq.Expressions
Provides classes, interfaces and enumerations that enable language-level code expressions to be represented as objects in the form of expression trees. Commonly Used Types: System.Linq.IQueryable<T> System.Linq.IQueryable System.Linq.Expressions.Expression<TDelegate> System.Linq.Expressions.Expression System.Linq.Expressions.ExpressionVisitor When using NuGet 3.x this package requires at least version 3.4.
7
System.ObjectModel
Provides types and interfaces that allow the creation of observable types that provide notifications to clients when changes are made to it. Commonly Used Types: System.ComponentModel.INotifyPropertyChanged System.Collections.ObjectModel.ObservableCollection<T> System.ComponentModel.PropertyChangedEventHandler System.Windows.Input.ICommand System.Collections.Specialized.INotifyCollectionChanged System.Collections.Specialized.NotifyCollectionChangedEventArgs System.Collections.Specialized.NotifyCollectionChangedEventHandler System.Collections.ObjectModel.KeyedCollection<TKey, TItem> System.ComponentModel.PropertyChangedEventArgs System.Collections.ObjectModel.ReadOnlyDictionary<TKey, TValue> When using NuGet 3.x this package requires at least version 3.4.
7
System.Security.Principal.Windows
Provides classes for retrieving the current Windows user and for interacting with Windows users and groups. Commonly Used Types: System.Security.Principal.WindowsIdentity System.Security.Principal.SecurityIdentifier System.Security.Principal.NTAccount System.Security.Principal.WindowsPrincipal System.Security.Principal.IdentityReference System.Security.Principal.IdentityNotMappedException System.Security.Principal.WindowsBuiltInRole System.Security.Principal.WellKnownSidType When using NuGet 3.x this package requires at least version 3.4.
17
System.ServiceModel.Primitives
Provides common Windows Communication Foundation (WCF) types for consuming and communicating with services. Commonly Used Types: System.ServiceModel.ClientBase<TChannel> System.ServiceModel.IClientChannel System.ServiceModel.ICommunicationObject System.ServiceModel.Channels.IChannel System.ServiceModel.IContextChannel System.ServiceModel.IExtensibleObject<T> System.ServiceModel.DataContractFormatAttribute System.ServiceModel.Description.IOperationBehavior System.ServiceModel.Channels.Message System.ServiceModel.FaultException<TDetail>
7
System.Threading.Tasks.Dataflow
TPL Dataflow promotes actor/agent-oriented designs through primitives for in-process message passing, dataflow, and pipelining. TDF builds upon the APIs and scheduling infrastructure provided by the Task Parallel Library (TPL), and integrates with the language support for asynchrony provided by C#, Visual Basic, and F#. Commonly Used Types: System.Threading.Tasks.Dataflow.ActionBlock<TInput> System.Threading.Tasks.Dataflow.BatchBlock<T> System.Threading.Tasks.Dataflow.BatchedJoinBlock<T1, T2> System.Threading.Tasks.Dataflow.BatchedJoinBlock<T1, T2, T3> System.Threading.Tasks.Dataflow.BroadcastBlock<T> System.Threading.Tasks.Dataflow.BufferBlock<T> System.Threading.Tasks.Dataflow.DataflowBlock System.Threading.Tasks.Dataflow.DataflowBlockOptions System.Threading.Tasks.Dataflow.DataflowLinkOptions System.Threading.Tasks.Dataflow.ExecutionDataflowBlockOptions System.Threading.Tasks.Dataflow.GroupingDataflowBlockOptions System.Threading.Tasks.Dataflow.JoinBlock<T1, T2> System.Threading.Tasks.Dataflow.JoinBlock<T1, T2, T3> System.Threading.Tasks.Dataflow.TransformBlock<TInput, TOutput> System.Threading.Tasks.Dataflow.TransformManyBlock<TInput, TOutput> System.Threading.Tasks.Dataflow.WriteOnceBlock<T>
6
System.Xml.XmlSerializer
Provides classes for serializing objects to the Extensible Markup Language (XML) and deserializing XML data to objects. Commonly Used Types: System.Xml.Serialization.IXmlSerializable System.Xml.Serialization.XmlSerializer System.Xml.Serialization.XmlIgnoreAttribute System.Xml.Serialization.XmlElementAttribute System.Xml.Serialization.XmlAttributeAttribute System.Xml.Serialization.XmlArrayAttribute System.Xml.Serialization.XmlRootAttribute System.Xml.Serialization.XmlArrayItemAttribute System.Xml.Serialization.XmlTypeAttribute System.Xml.Serialization.XmlEnumAttribute
6

.NETPlatform 5.0

.NET Framework 4.5

  • No dependencies.

Windows 8.0

  • No dependencies.

.NETCore 5.0

Version Downloads Last updated
4.3.0 8 04/24/2026
4.3.0-preview1-24530-04 5 04/24/2026
4.0.11 5 04/24/2026
4.0.11-rc2-24027 5 04/25/2026
4.0.11-beta-23516 5 04/25/2026
4.0.11-beta-23409 5 04/25/2026
4.0.11-beta-23225 5 04/25/2026
4.0.10 5 04/24/2026
4.0.10-beta-23109 5 04/25/2026
4.0.10-beta-23019 5 04/25/2026
4.0.10-beta-22816 5 04/25/2026
4.0.10-beta-22605 5 04/25/2026
4.0.0 5 04/24/2026
4.0.0-beta-23109 5 04/24/2026
4.0.0-beta-23019 5 04/24/2026
4.0.0-beta-22416 6 04/16/2026
4.0.0-beta-22231 5 04/24/2026