System.Text.Encoding 4.0.10-beta-22816

Provides base abstract encoding classes for converting blocks of characters to and from blocks of bytes. Commonly Used Types: System.Text.Encoding System.Text.DecoderFallbackException System.Text.Decoder System.Text.EncoderFallbackException System.Text.Encoder System.Text.EncoderFallback System.Text.EncoderFallbackBuffer System.Text.DecoderFallback System.Text.DecoderFallbackBuffer System.Text.DecoderExceptionFallback

Showing the top 20 packages that depend on System.Text.Encoding.

Packages Downloads
log4net
log4net is a tool to help the programmer output log statements to a variety of output targets. In case of problems with an application, it is helpful to enable logging so that the problem can be located. With log4net it is possible to enable logging at runtime without modifying the application binary. The log4net package is designed so that log statements can remain in shipped code without incurring a high performance cost. It follows that the speed of logging (or rather not logging) is crucial. At the same time, log output can be so voluminous that it quickly becomes overwhelming. One of the distinctive features of log4net is the notion of hierarchical loggers. Using these loggers it is possible to selectively control which log statements are output at arbitrary granularity. log4net is designed with two distinct goals in mind: speed and flexibility
8
Microsoft.Data.Analysis
This package contains easy-to-use and high-performance libraries for data analysis and transformation.
10
Microsoft.IdentityModel.JsonWebTokens
Includes types that provide support for creating, serializing and validating JSON Web Tokens.
17
Microsoft.IdentityModel.Protocols.OpenIdConnect
Includes types that provide support for OpenIdConnect protocol.
17
Microsoft.IdentityModel.Tokens
Includes types that provide support for SecurityTokens, Cryptographic operations: Signing, Verifying Signatures, Encryption.
17
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. 57a0c74f36c8b254211c16547f6249b6604d527d When using NuGet 3.x this package requires at least version 3.4.
6
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. 81ffa9f5381f510c2afa17a113e4c4d77144b84e When using NuGet 3.x this package requires at least version 3.4.
6
NETStandard.Library
A set of standard .NET API's that are prescribed to be used and supported together. This includes all low level API's that all .NET platforms must support. TFS ID: 1599443, GitHub SHA: https://github.com/dotnet/corefx/tree/eede273a4dfabcea608621f5e1bbf8ad00584cfb
6
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform. When using NuGet 3.x this package requires at least version 3.4.
29
Portable.BouncyCastle
BouncyCastle.Crypto is a cryptography API providing: -Generation and parsing of PKCS#12 files. -X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. -PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. -Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. -Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC. -Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). -Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte. -Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA. -Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1. -Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool. -Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA. -Key Agreement: Diffie-Hellman and EC-DH. -Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3. -PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2. -OpenPGP (RFC 2440) -Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. -Online Certificate Status Protocol (OCSP, RFC 2560). -Time Stamp Protocol (TSP, RFC 3161). -TLS/SSL Client with support for client side authentication. Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR
6
System.IO
Provides base input and output (I/O) types, including System.IO.Stream, System.IO.StreamReader and System.IO.StreamWriter, that allow reading and writing to data streams Commonly Used Types: System.IO.Stream System.IO.EndOfStreamException System.IO.MemoryStream System.IO.StreamReader System.IO.StreamWriter System.IO.StringWriter System.IO.TextWriter System.IO.TextReader When using NuGet 3.x this package requires at least version 3.4.
11
System.IO.Packaging
Provides classes that support storage of multiple data objects in a single container. When using NuGet 3.x this package requires at least version 3.4.
6
System.Net.Http
Provides a programming interface for modern HTTP applications, including HTTP client components that allow applications to consume web services over HTTP and HTTP components that can be used by both clients and servers for parsing HTTP headers. Commonly Used Types: System.Net.Http.HttpResponseMessage System.Net.Http.DelegatingHandler System.Net.Http.HttpRequestException System.Net.Http.HttpClient System.Net.Http.MultipartContent System.Net.Http.Headers.HttpContentHeaders System.Net.Http.HttpClientHandler System.Net.Http.StreamContent System.Net.Http.FormUrlEncodedContent System.Net.Http.HttpMessageHandler When using NuGet 3.x this package requires at least version 3.4.
6
System.Security.Cryptography.Algorithms
Provides base types for cryptographic algorithms, including hashing, encryption, and signing operations. Commonly Used Types: System.Security.Cryptography.Aes System.Security.Cryptography.RSA System.Security.Cryptography.RSAParameters System.Security.Cryptography.HMACSHA1 System.Security.Cryptography.SHA256 System.Security.Cryptography.SHA1 System.Security.Cryptography.SHA512 System.Security.Cryptography.SHA384 System.Security.Cryptography.HMACSHA256 System.Security.Cryptography.MD5 System.Security.Cryptography.HMACSHA384 System.Security.Cryptography.HMACSHA512 When using NuGet 3.x this package requires at least version 3.4.
6
System.Security.Cryptography.Cng
Provides cryptographic algorithm implementations and key management with Windows Cryptographic Next Generation API (CNG). Commonly Used Types: System.Security.Cryptography.RSACng System.Security.Cryptography.ECDsaCng System.Security.Cryptography.CngKey 30ab651fcb4354552bd4891619a0bdd81e0ebdbf When using NuGet 3.x this package requires at least version 3.4.
7
System.Security.Cryptography.Cng
Provides cryptographic algorithm implementations and key management with Windows Cryptographic Next Generation API (CNG). Commonly Used Types: System.Security.Cryptography.RSACng System.Security.Cryptography.ECDsaCng System.Security.Cryptography.CngKey When using NuGet 3.x this package requires at least version 3.4.
17
System.Security.Principal.Windows
Provides classes for retrieving the current Windows user and for interacting with Windows users and groups. Commonly Used Types: System.Security.Principal.WindowsIdentity System.Security.Principal.SecurityIdentifier System.Security.Principal.NTAccount System.Security.Principal.WindowsPrincipal System.Security.Principal.IdentityReference System.Security.Principal.IdentityNotMappedException System.Security.Principal.WindowsBuiltInRole System.Security.Principal.WellKnownSidType When using NuGet 3.x this package requires at least version 3.4.
17
System.ServiceModel.Primitives
Provides common Windows Communication Foundation (WCF) types for consuming and communicating with services. Commonly Used Types: System.ServiceModel.ClientBase<TChannel> System.ServiceModel.IClientChannel System.ServiceModel.ICommunicationObject System.ServiceModel.Channels.IChannel System.ServiceModel.IContextChannel System.ServiceModel.IExtensibleObject<T> System.ServiceModel.DataContractFormatAttribute System.ServiceModel.Description.IOperationBehavior System.ServiceModel.Channels.Message System.ServiceModel.FaultException<TDetail>
7
System.Xml.ReaderWriter
Provides provides a fast, non-cached, forward-only way to read and write Extensible Markup Language (XML) data. Commonly Used Types: System.Xml.XmlNodeType System.Xml.XmlException System.Xml.XmlReader System.Xml.XmlWriter System.Xml.IXmlLineInfo System.Xml.XmlNameTable System.Xml.IXmlNamespaceResolver System.Xml.XmlNamespaceManager System.Xml.XmlQualifiedName When using NuGet 3.x this package requires at least version 3.4.
6
System.Xml.XDocument
Provides the classes for Language-Integrated Query (LINQ) to Extensible Markup Language (XML). LINQ to XML is an in-memory XML programming interface that enables you to modify XML documents efficiently and easily. Commonly Used Types: System.Xml.Linq.XElement System.Xml.Linq.XAttribute System.Xml.Linq.XDocument System.Xml.Linq.XText System.Xml.Linq.XNode System.Xml.Linq.XContainer System.Xml.Linq.XComment System.Xml.Linq.XObject System.Xml.Linq.XProcessingInstruction System.Xml.Linq.XDocumentType When using NuGet 3.x this package requires at least version 3.4.
6

Any 0.0

Version Downloads Last updated
4.3.0 14 05/16/2026
4.3.0-preview1-24530-04 5 04/24/2026
4.0.11 5 04/24/2026
4.0.11-rc2-24027 5 04/25/2026
4.0.11-beta-23516 5 04/25/2026
4.0.11-beta-23409 5 04/25/2026
4.0.11-beta-23225 5 04/25/2026
4.0.10 5 04/24/2026
4.0.10-beta-23109 5 04/25/2026
4.0.10-beta-23019 5 04/25/2026
4.0.10-beta-22816 5 04/25/2026
4.0.10-beta-22605 5 04/25/2026
4.0.10-beta-22416 6 04/16/2026
4.0.10-beta-22231 5 04/24/2026
4.0.0 5 04/24/2026
4.0.0-beta-23109 5 04/25/2026
4.0.0-beta-23019 5 04/25/2026