System.Text.Encoding 4.3.0-preview1-24530-04

Provides base abstract encoding classes for converting blocks of characters to and from blocks of bytes. Commonly Used Types: System.Text.Encoding System.Text.DecoderFallbackException System.Text.Decoder System.Text.EncoderFallbackException System.Text.Encoder System.Text.EncoderFallback System.Text.EncoderFallbackBuffer System.Text.DecoderFallback System.Text.DecoderFallbackBuffer System.Text.DecoderExceptionFallback When using NuGet 3.x this package requires at least version 3.4.

Showing the top 20 packages that depend on System.Text.Encoding.

Packages Downloads
log4net
log4net is a tool to help the programmer output log statements to a variety of output targets. In case of problems with an application, it is helpful to enable logging so that the problem can be located. With log4net it is possible to enable logging at runtime without modifying the application binary. The log4net package is designed so that log statements can remain in shipped code without incurring a high performance cost. It follows that the speed of logging (or rather not logging) is crucial. At the same time, log output can be so voluminous that it quickly becomes overwhelming. One of the distinctive features of log4net is the notion of hierarchical loggers. Using these loggers it is possible to selectively control which log statements are output at arbitrary granularity. log4net is designed with two distinct goals in mind: speed and flexibility
8
Microsoft.Data.Analysis
This package contains easy-to-use and high-performance libraries for data analysis and transformation.
10
Microsoft.IdentityModel.JsonWebTokens
Includes types that provide support for creating, serializing and validating JSON Web Tokens.
17
Microsoft.IdentityModel.Protocols.OpenIdConnect
Includes types that provide support for OpenIdConnect protocol.
17
Microsoft.IdentityModel.Tokens
Includes types that provide support for SecurityTokens, Cryptographic operations: Signing, Verifying Signatures, Encryption.
17
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. b7f182415927d3b98445d043e1680c56b9d1f17c When using NuGet 3.x this package requires at least version 3.4.
6
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform. When using NuGet 3.x this package requires at least version 3.4.
29
Portable.BouncyCastle
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you. Crypto features: - Generation and parsing of PKCS-12 files. - X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. - PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. - Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. - Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20. - Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). - Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte. - Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding). - Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1. - AEAD block cipher modes: CCM, EAX, GCM and OCB. - Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool. - XOFs: SHAKE. - Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998. - Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a. - Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC. - PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2. - OpenPGP (RFC 4880) - Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. - Online Certificate Status Protocol (OCSP, RFC 2560). - Time Stamp Protocol (TSP, RFC 3161). - TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available. - Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves. - Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions. - PKIX certificate path validation
6
StackExchange.Redis
High performance Redis client, incorporating both synchronous and asynchronous usage.
6
System.IO
Provides base input and output (I/O) types, including System.IO.Stream, System.IO.StreamReader and System.IO.StreamWriter, that allow reading and writing to data streams Commonly Used Types: System.IO.Stream System.IO.EndOfStreamException System.IO.MemoryStream System.IO.StreamReader System.IO.StreamWriter System.IO.StringWriter System.IO.TextWriter System.IO.TextReader When using NuGet 3.x this package requires at least version 3.4.
11
System.IO.Compression
Provides classes that support the compression and decompression of streams. Commonly Used Types: System.IO.Compression.DeflateStream System.IO.Compression.GZipStream System.IO.Compression.CompressionMode System.IO.Compression.CompressionLevel System.IO.Compression.ZipArchiveEntry System.IO.Compression.ZipArchive System.IO.Compression.ZipArchiveMode
6
System.Security.Cryptography.Algorithms
Provides base types for cryptographic algorithms, including hashing, encryption, and signing operations. Commonly Used Types: System.Security.Cryptography.Aes System.Security.Cryptography.RSA System.Security.Cryptography.RSAParameters System.Security.Cryptography.HMACSHA1 System.Security.Cryptography.SHA256 System.Security.Cryptography.SHA1 System.Security.Cryptography.SHA512 System.Security.Cryptography.SHA384 System.Security.Cryptography.HMACSHA256 System.Security.Cryptography.MD5 System.Security.Cryptography.HMACSHA384 System.Security.Cryptography.HMACSHA512
6
System.Security.Cryptography.Cng
Provides cryptographic algorithm implementations and key management with Windows Cryptographic Next Generation API (CNG). Commonly Used Types: System.Security.Cryptography.RSACng System.Security.Cryptography.ECDsaCng System.Security.Cryptography.CngKey 30ab651fcb4354552bd4891619a0bdd81e0ebdbf When using NuGet 3.x this package requires at least version 3.4.
7
System.Security.Cryptography.Cng
Provides cryptographic algorithm implementations and key management with Windows Cryptographic Next Generation API (CNG). Commonly Used Types: System.Security.Cryptography.RSACng System.Security.Cryptography.ECDsaCng System.Security.Cryptography.CngKey When using NuGet 3.x this package requires at least version 3.4.
17
System.Security.Cryptography.Encoding
Provides types for representing Abstract Syntax Notation One (ASN.1)-encoded data. Commonly Used Types: System.Security.Cryptography.AsnEncodedData System.Security.Cryptography.Oid System.Security.Cryptography.OidCollection When using NuGet 3.x this package requires at least version 3.4.
6
System.Security.Principal.Windows
Provides classes for retrieving the current Windows user and for interacting with Windows users and groups. Commonly Used Types: System.Security.Principal.WindowsIdentity System.Security.Principal.SecurityIdentifier System.Security.Principal.NTAccount System.Security.Principal.WindowsPrincipal System.Security.Principal.IdentityReference System.Security.Principal.IdentityNotMappedException System.Security.Principal.WindowsBuiltInRole System.Security.Principal.WellKnownSidType When using NuGet 3.x this package requires at least version 3.4.
17
System.ServiceModel.Http
Provides classes that allow applications to consume HTTP and WebSocket web services. Use the System.ServiceModel.BasicHttpBinding class for communication with ASMX-based web services and other services that conform to the WS-I Basic Profile 1.1. Whereas, use the System.ServiceModel.NetHttpBinding class for communication with .NET-based WebSocket services. Commonly Used Types: System.ServiceModel.BasicHttpBinding System.ServiceModel.Channels.HttpRequestMessageProperty System.ServiceModel.Channels.HttpResponseMessageProperty System.ServiceModel.Channels.HttpTransportBindingElement System.ServiceModel.Channels.HttpsTransportBindingElement System.ServiceModel.HttpClientCredentialType System.ServiceModel.BasicHttpSecurityMode System.ServiceModel.HttpTransportSecurity System.ServiceModel.BasicHttpMessageCredentialType System.ServiceModel.HttpBindingBase
6
System.ServiceModel.Primitives
Provides common Windows Communication Foundation (WCF) types for consuming and communicating with services. Commonly Used Types: System.ServiceModel.ClientBase<TChannel> System.ServiceModel.IClientChannel System.ServiceModel.ICommunicationObject System.ServiceModel.Channels.IChannel System.ServiceModel.IContextChannel System.ServiceModel.IExtensibleObject<T> System.ServiceModel.DataContractFormatAttribute System.ServiceModel.Description.IOperationBehavior System.ServiceModel.Channels.Message System.ServiceModel.FaultException<TDetail>
7
System.ServiceModel.Primitives
Provides common Windows Communication Foundation (WCF) types for consuming and communicating with services. Commonly Used Types: System.ServiceModel.ClientBase<TChannel> System.ServiceModel.IClientChannel System.ServiceModel.ICommunicationObject System.ServiceModel.Channels.IChannel System.ServiceModel.IContextChannel System.ServiceModel.IExtensibleObject<T> System.ServiceModel.DataContractFormatAttribute System.ServiceModel.Description.IOperationBehavior System.ServiceModel.Channels.Message System.ServiceModel.FaultException<TDetail> \r\n TFS ID: 1599443, GitHub SHA: https://github.com/dotnet/corefx/tree/eede273a4dfabcea608621f5e1bbf8ad00584cfb
6
System.Text.Encoding.Extensions
Provides support for specific encodings, including ASCII, UTF-7, UTF-8, UTF-16, and UTF-32. Commonly Used Types: System.Text.UTF8Encoding System.Text.UnicodeEncoding System.Text.ASCIIEncoding System.Text.UTF7Encoding System.Text.UTF32Encoding
6

MonoAndroid 1.0

  • No dependencies.

MonoTouch 1.0

  • No dependencies.

.NET Framework 4.5

  • No dependencies.

.NETCore 5.0

.NET Standard 1.0

.NET Standard 1.3

.NETPortable 0.0

  • No dependencies.

Windows 8.0

  • No dependencies.

WindowsPhone 8.0

  • No dependencies.

WindowsPhoneApp 8.1

  • No dependencies.

Xamarin.iOS 1.0

  • No dependencies.

Xamarin.Mac 2.0

  • No dependencies.

Xamarin.TVOS 1.0

  • No dependencies.

Xamarin.WatchOS 1.0

  • No dependencies.

Version Downloads Last updated
4.3.0 14 05/16/2026
4.3.0-preview1-24530-04 5 04/24/2026
4.0.11 5 04/24/2026
4.0.11-rc2-24027 5 04/25/2026
4.0.11-beta-23516 5 04/25/2026
4.0.11-beta-23409 5 04/25/2026
4.0.11-beta-23225 5 04/25/2026
4.0.10 5 04/24/2026
4.0.10-beta-23109 5 04/25/2026
4.0.10-beta-23019 5 04/25/2026
4.0.10-beta-22816 5 04/25/2026
4.0.10-beta-22605 5 04/25/2026
4.0.10-beta-22416 6 04/16/2026
4.0.10-beta-22231 5 04/24/2026
4.0.0 5 04/24/2026
4.0.0-beta-23109 5 04/25/2026
4.0.0-beta-23019 5 04/25/2026